Linux in tasca: Slax & P5B-E


Slax mi piace molto, è davvero portabile ed utilizzabile su una USB, parte già completo di tutto quello che davvero serve e, se si vuole, potete espanderlo con una facilità disarmante tramite i modules.

Su 3 dei miei 4 computer funziona perfettamente, ma su uno, quello che ha come motherboard una Asus P5B-E e come scheda video una ATI 1950 Pro, purtroppo ho avuto problemi. Niente rete e video impossibile da far funzionare alla definizione giusta per il mio monitor.

Che fare allora? Con un po di pazienza e di ricerca su Internet ho sistemato tutto….

Per prima cosa i driver ATI. Questo è stato veramente facile.

Premetto che sto utilizzando Slax 6 rc4, quindi non si tratta di una versione considerata stabile, ma sapete com’è, mi piace stare al passo.

In pratica è bastato andare sul sito SLAX, nella sezione dedicata ai moduli dei drivers, e scaricare il modulo contenente i drivers ATI a configurazione automatica, copiarli nella directory /slax/modules della penna USB e riavviare. Unico difetto i fonts delle applicazioni un po grandi, poi studierò il modo di ridurli in qualche modo….

La cosa un pochino più laboriosa è stata quella di far funzionare la scheda di rete. Sapete com’è se non funziona la scheda di rete c’è poco da divertirsi…

La mia motherboard ha come scheda di rete incorporata una Attansic L1 Gigabit. Come al solito Internet aiuta, e non ci è voluto molto per trovare la pagina da cui scaricare i driver (in teoria dovevano essere già nel kernel visto che Slax utilizza il kernel 2.6.21, ma per qualche motivo non ci sono…).

Una volta scaricati i driver e copiato il file sulla pennina, ho avviato Slax dalla USB ed ho eseguito i comandi per la compilazione, come da documento allegato ai driver.

atl2.pngPurtroppo ho avuto un paio di errori di compilazione, non so se dovuti alla configurazione di Slax (non ho installato nulla relativo agli strumenti di sviluppo) o altro. Armato di fiducioso spirito esplorativo mi sono limitato a commentare le due righe che davano errore (credo fossero relative alle vlan, quindi in fondo non è una parte del driver che dovrei usare).

Effettuata compilazione e installazione del driver ho riavviato et voilà tutto funziona perfettamente (ovviamente stavo lavorando in maniera persistente in modo da salvaguardare i cambiamenti che avevo fatto)
atl1.pngA questo punto ho vuoluto fare una prova ulteriore, ho copiato l’intera struttura del file system dove si trova il driver (atl1.ko) in una directory di appoggio e da qui ho creato con il comando dir2lzm un modulo Slax contenente il driver (questo per evitare che tutta la struttura dei drivers di sistema venisse aggiunta al modulo, volevo solo il driver atl1.ko).

Ho inserito il file atl1.lzm così creato nella directory /slax/optional della penna USB, ho fatto il reboot, ma stavolta non sono partito con la configurazione persistente, ho scelto invece quella “live” aggiungendo però il parametro load=atl1 alla riga di partenza del kernel…

Anche così il sistema si avvia supportando la scheda di rete e questo modulino quindi mi sarà utile per non dover eseguire la compilazione in occasione delle prossime release di Slax….

Probabilmente non ho fatto tutto nel migliore dei modi, ma che vi devo dire, le cose funzionano e non chiedo di più 🙂

Ora ho un paio di altre distribuzioni che avevano lo stesso problema ed avevo scartato durante la prima tornata di test, ci tornerò sopra, magari riesco a far funzionare anche quelle…..

Annunci

2 commenti (+aggiungi il tuo?)

  1. Valerio
    Feb 29, 2008 @ 17:16:43

    Ciao, interessante intervento, e molto tempestivo visto che slax 6.0.1 è stato rilasciato ieri

    In ogni caso se postassi il file .lzm da qualche parte risparmieresti molto tempo a tutti i poveretti con questo chip ethernet 😀

    inoltre a questo indirizzo: http://www.slax.org/forum.php?action=view&parentID=234
    c’è la lista dei moduli personalizzati per slax, magari potresti aggiungerlo anche là

    Rispondi

  2. Mario
    Mar 03, 2008 @ 10:55:41

    Non sono sicuro che con la 6.01 non siano già presenti i driver di quella scheda, farò una prova a casa. In ogni caso non ho messo online il modulino perché non sono sicuro di come funzionino i copyright, comunque il procedimento per la compilazione non è poi così complesso…

    Rispondi

Rispondi

Inserisci i tuoi dati qui sotto o clicca su un'icona per effettuare l'accesso:

Logo WordPress.com

Stai commentando usando il tuo account WordPress.com. Chiudi sessione / Modifica )

Foto Twitter

Stai commentando usando il tuo account Twitter. Chiudi sessione / Modifica )

Foto di Facebook

Stai commentando usando il tuo account Facebook. Chiudi sessione / Modifica )

Google+ photo

Stai commentando usando il tuo account Google+. Chiudi sessione / Modifica )

Connessione a %s...

%d blogger hanno fatto clic su Mi Piace per questo: